SPRITEKING

虚拟局域网VLAN

时间:公元13-11-22 栏目:思科路由交换, 网络工程 作者:SPRITEKING 吐槽:0 被黑客围观: 869 次





  • 理解VLAN的原理
  • 理解Trunk的原理
  • 会配置VLAN和Trunk
  • 会配置以太网通道

 

  • VLAN 全称 Virtual Local Area Network 即:虚拟局域网

 

 

  • 1
  • VLAN概述与优势

 

  • 分割广播域
  • 物理分割
  • 逻辑分割
  • VLAN的优势
  • 控制广播
  • 增强网络安全性
  • 简化网络管理
  • 2

 

 

  • VLAN的种类
  • 静态VLAN
  • 基于端口划分静态VLAN
  • 3
  • 动态VLAN
  • 基于MAC地址划分动态VLAN
  • 静态VLAN的配置

 

  • VLAN的范围
  • 4
  • 静态VLAN的配置:
  • 配置静态VLAN的步骤

 

  • 创建VLAN
  • 将交换机的端口加入到相应的VLAN中
  • 验证VLAN的配置
  • 创建VLAN有两种方法:
  • 1.VLAN数据库配置模式
  • Switch#vlan database 进入VLAN数据库模式
  • Switch(vlan)#vlan vlan-id [name vlan-name] 添加VLAN并命名,如不指定名称,系统会使用默认名称.
  • Switch(vlan)#exit 保存退出

 

  • 2.全局配置模式
  • Switch(config)#vlan vlan-id 添加一个VLAN
  • Switch(config-vlan)#name vlan-name 给VLAN命名,此命令可选

 

  • (创建VLAN示例)
  • VLAN数据库配置模式创建VLAN
  • Switch#vlan database
  • Switch(vlan)#vlan 2 name test20 添加VLAN2,并命名为test20;如果不指定VLAN名称,交换机自动,使用默认名称VLAN0002.
  • VLAN 2 added:
  • Name: test20
  • Switch(vlan)#exit 保存并退出
  • APPLY completed.
  • Exiting....

 

  • 全局配置模式创建VLAN
  • Switch(config)#vlan 2
  • Switch(config-vlan)#name test20 命名为test20(可选)
  • 删除VLAN
  • 删除VLAN
  • 使用no vlan vlan-id命令删除VLAN

 

  • VLAN数据库中删除VLAN
  • Switch# vlan database
  • Switch(vlan)# no vlan 20
  • Deleting VLAN 20...
  • Switch(vlan)#exit
  • APPLY completed.
  • Exiting....

 

  • 全局模式下删除VLAN
  • Switch# configure terminal
  • Switch(config)# no vlan 20
  • 将端口加入VLAN
  • Switch(config)# interface interface-id 进入要配置的端口
  • Switch(config-if)# switchport mode access 定义二层端口模式
  • Switch(config-if)# switchport access vlan vlan-id 将端口添加到VLAN中
  • Switch(config-if)# no switchport access vlan vlan-id 将端口从某个VLAN中删除
  • 同时将多个端口加入VLAN
  • Switch(config)# interface range f0/1 – 10
  • Switch(config-if-range)# switchport access vlan vlan-id

 

  • 还原接口为默认配置状态
  • Switch(config)# default interface interfaceSwitch(config)# interface interface-id
  • Switch(config-if)# switchport mode access
  • Switch(config-if)# switchport access vlan vlan-id
  • Switch(config-if)# no switchport access vlan vlan-id
  • -id

 

  • 验证VLAN的配置
  • 查看所有VLAN的摘要信息 Switch# show vlan brief
  • 查看指定VLAN信息 Switch# show vlan id vlan-id

 

  • VLAN配置实例
  • 需求描述
  • 创建VLAN 10、20、30,VLAN 30命名为caiwu
  • 如图所示将交换机端口添加到VLAN中
  • 5
  • Switch(config)#vlan 10,20
  • Switch(config-vlan)#exit
  • Switch(config)#vlan 30
  • Switch(config-vlan)#name caiwu
  • Switch(config-vlan)#exit
  • Switch(config)#interface range f0/5 – 10
  • Switch(config-if-range)#switchport mode access
  • Switch(config-if-range)#switchport access vlan 10
  • Switch(config-if-range)#exit
  • Switch(config)#interface range f0/11 – 15
  • Switch(config-if-range)#switchport mode access
  • Switch(config-if-range)#switchport access vlan 20
  • Switch(config-if-range)#exit
  • Switch(config)#interface range f0/16 – 20
  • Switch(config-if-range)#switchport mode access
  • Switch(config-if-range)#switchport access vlan 30
  • Switch(config-if-range)#end
  • Switch#show vlan brief
  • VLAN Name Status Ports
  • ---- --------------------------- --------- -------------------------------
  • 1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
  • Fa0/21, Fa0/22,Fa0/23, Fa0/24
  • 10 VLAN0010 active Fa0/5, Fa0/6, Fa0/7, Fa0/8
  • Fa0/9, Fa0/10
  • 20 VLAN0020 active Fa0/11, Fa0/12, Fa0/13, Fa0/14
  • Fa0/15
  • 30 caiwu active Fa0/16, Fa0/17, Fa0/18,Fa0/19
  • Fa0/20
  • 1002 fddi-default act/unsup
  • 1003 token-ring-default act/unsup
  • 1004 fddinet-default act/unsup
  • 1005 trnet-default act/unsup

 

  • Trunk的作用
  • 如何实现交换机之间的VLAN通信
  • 为每一个VLAN提供一条链路?
  • 6

 

  • 那么,如何实现交换机之间的VLAN通信呢?
  • 其实可以只使用一条链路,且通过标识来区分不同VLAN的数据
  • 7

 

  • 交换网络中的链路类型
  • 接入链路
  • 中继链路
  • 8

 

  • VLAN跨交换机通信过程
  • 交换机给往其他交换机的数据帧打上VLAN标识
  • 9
  • VLAN的标识

 

  • 在以太网上实现中继,有两种封装类型

 

  • ISL(Cisco私有标准) 适用于思科设备之间相互通信
  • IEEE 802.1q(标准通用) 适用于非思科设备 及 思科和非思科设备 之间的相互通信
  • ISL帧格式
  • 10
  • IEEE 802.1q工作原理
  • 11
  • IEEE 802.1q帧格式
  • 12
  • Native VLAN:
  • 不支持VLAN的交换机混合部署
  • 允许交换机从Trunk端口上转发未被标记的帧
  • Cisco Catalyst交换机默认Native VLAN是VLAN 1
  • Trunk端口互联Native VLAN必须相同
  • 13
  • Trunk的模式和协商
  • DTP动态中继协议
  • Trunk的模式
  • 接入(Access)
  • 干道(Trunk)
  • 动态企望(Dynamic desirable)
  • 动态自动(Dynamic auto)
  • 非协商(Nonegotiate)
  • Trunk模式协商结果
  • 14

 

  • Trunk的配置

 

  • 配置步骤与命令
  • 进入接口配置模式 Switch(config)#interface interface-id
  • 选择封装类型 Switch(config-if)#switchport trunk encapsulation { isl | dot1q | negotiate }
  • 将接口配置为Trunk Switch(config-if)#switchport mode {dynamic {desirable | auto} | trunk | access}
  • 指定Native VLAN(可选)
  • Switch(config-if)#switchport trunk native vlan vlan-id
  • 其他配置
  • 禁止Trunk传送某个VLAN的数据,删除这个VLAN Switch(config-if)#switchport trunk allowed vlan remove vlan-id
  • 允许Trunk传送某个VLAN的数据,添加这个VLAN Switch(config-if)#switchport trunk allowed vlan add vlan-id 默认允许全部VLAN的数据通过
  • 查看接口模式、状态 : Switch#show interface interface-id switchport

 

  • Trunk配置实例
  • 需求描述
  • SW1和SW2各创建3个VLAN,VLAN 1、2、3;
  • 交换机端口分配:VLAN 1:F0/1~F0/3;VLAN 2:F0/4~F0/10;VLAN 3:F0/11~F0/23
  • 15
  • 查看端口模式、状态
  • SW1#show interface f0/24 switchport
  • Name: Fa0/24
  • Switchport: Enabled
  • Administrative Mode: trunk 接口模式配置为Trunk
  • Operational Mode: trunk 接口工作模式为Trunk
  • Administrative Trunking Encapsulation: dot1q
  • Operational Trunking Encapsulation: dot1q Trunk协议类型为802.1q
  • Negotiation of Trunking: On
  • Access Mode VLAN: 1 (default)
  • Trunking Native Mode VLAN: 1 (default)
  • Voice VLAN: none
  • Administrative private-vlan host-association: none
  • Administrative private-vlan mapping: none
  • Operational private-vlan: none
  • Trunking VLANs Enabled: ALL Trunk可以承载所有的VLAN
  • Pruning VLANs Enabled: 2-1001
  • Capture Mode Disabled
  • Capture VLANs Allowed: ALL

 

  • runk链路上移除VLAN 2
  • SW1(config)#interface f0/24
  • SW1(config-if)#switchport trunk allowed vlan remove 2

 

  • 查看端口模式、状态
  • SW1#show interface f0/24 switchport
  • Name: Fa0/24
  • Switchport: Enabled
  • Administrative Mode: trunk
  • Operational Mode: trunk
  • …………
  • Operational private-vlan: none
  • Trunking VLANs Enabled: 1,3-1005 不允许VLAN 2数据通过
  • Pruning VLANs Enabled: 2-1001
  • Capture Mode Disabled

 

  • Trunk的排错
  • Trunk链路无法建立
  • 接口模式
  • 封装类型
  • Native VLAN
  • 16
  • 检查交换机配置保证同一Vlan内主机可以通信
  • SW1交换机配置 SW2交换机配置
  • interface FastEthernet0/1                                        interface FastEthernet0/1
  • switchport access vlan 2                                          switchport access vlan 2
  • switchport mode access                                          switchport mode access
  • !                                                                                  !
  • interface FastEthernet0/2                                        interface FastEthernet0/2
  • switchport access vlan 3                                          switchport access vlan 3
  • switchport mode access                                           switchport mode access
  • !                                                                                  !
  • interface FastEthernet0/24                                      interface FastEthernet0/24
  • switchport mode dynamic auto                               switchport mode dynamic auto

 

  • 配置以太网通道

 

  • EthernetChannel-以太通道
  • 多条线路负载均衡,带宽提高
  • 容错,当一条线路失效时,其他线路通信,不会丢包
  • 17
  • 配置接口为以太通道模式
  • Switch(config)# interface range fastEthernet 0/1 – 2 (fastEthernet 0/1 – 2 要捆绑在一起的端口)
  • Switch(config-if-range)#channel-group 1 mode on (group 1以太通道的组号)
  • Creating a port-channel interface Port-channel 1
  • 18
  • 查看以太通道的配置
  • Switch# show etherchannel 1 summary
  • Flags: D - down P - in port-channel
  • I - stand-alone s - suspended
  • H - Hot-standby (LACP only)
  • R - Layer3 S - Layer2
  • U - in use f - failed to allocate aggregator
  • u - unsuitable for bundling
  • w - waiting to be aggregated
  • d - default port
  • Number of channel-groups in use: 1
  • Number of aggregators: 1
  • Group Port-channel Protocol Ports
  • ------+-------------+-----------+-----------------------------------------------
  • 1 Po1(SU) - Fa0/23(P) Fa0/24(P)

声明: 本文由( SPRITEKING )原创编译,转载请保留链接: 虚拟局域网VLAN

虚拟局域网VLAN:等您坐沙发呢!

发表评论


Time

新浪微博

音乐

为您推荐